the crack is gone

Incident Report for AngelicDust

Resolved

we are high again
Posted Jul 22, 2025 - 22:22 EDT

Monitoring

our dealer has finally resurfaced and said he can hook us up. we are checking to see if he is an undercover cop first.
Posted Jul 07, 2025 - 01:49 EDT

Update

we're still trying to get more crack to smoke
Posted Dec 28, 2024 - 19:35 EST

Identified

we smoked all the crack its fucking over
Posted Oct 14, 2024 - 19:29 EDT